#85 closed defect (fixed)

testsuite: Some simulator tests fail consistently on Fedora

Reported by: Lukáš Zaoral Owned by: mornfall
Priority: major Milestone: 4.4
Component: sim Keywords:
Cc: kdudka@…, jamartis@…, lzaoral@…

Description

Hello,
the following simulator tests fail consistently with the same error outputs on Fedora 30 and Fedora 31 beta. The semidbg builds fail too. Thanks.

Failing simulator tests:

  • sim/bitfield.sh
  • sim/show-atomic.sh
  • sim/step-states.sh

Attachments (3)

bitfield.log (9.0 KB) - added by Lukáš Zaoral 11 months ago.
show-atomic.log (8.4 KB) - added by Lukáš Zaoral 11 months ago.
step-states.log (16.4 KB) - added by Lukáš Zaoral 11 months ago.

Download all attachments as: .zip

Change History (5)

Changed 11 months ago by Lukáš Zaoral

Attachment: bitfield.log added

Changed 11 months ago by Lukáš Zaoral

Attachment: show-atomic.log added

Changed 11 months ago by Lukáš Zaoral

Attachment: step-states.log added

comment:1 Changed 10 months ago by mornfall

Milestone: 4.34.4
Status: newaccepted

Seems to be a problem with debug paths in DiOS: /dios/include/_build.release/dios/include/sys/divm.h:490 (should definitely not have _build.release in the path).

comment:2 Changed 10 months ago by mornfall

Resolution: fixed
Status: acceptedclosed

Indeed, I managed to reproduce the problem. Should be fixed in next.

Note: See TracTickets for help on using tickets.