Opened 10 months ago

Closed 4 months ago

#75 closed defect (fixed)

cmake: Build of 4.4.2 fails due to missing target dependencies

Reported by: Lukáš Zaoral Owned by: mornfall
Priority: major Milestone: 4.4
Component: other Keywords:
Cc: kdudka@…, jamartis@…

Description

Hi,
if I try to build latest release of Divine without ninja, the build fails. I have tried Fedora 30 and the latest release of Manjaro Linux. Both distros fail consistently even on older releases from 4.3 series. However, each distro fails at a different point of compilation.

Everything builds fine with ninja, so this is a rather minor issue.
Thanks.

Attachments (3)

fedora-30-no-ninja-4.3.4.txt (1.6 KB) - added by Lukáš Zaoral 10 months ago.
manjaro-no-ninja-4.3.4.txt (1.7 KB) - added by Lukáš Zaoral 10 months ago.
target_deps.patch (1.5 KB) - added by Lukáš Zaoral 4 months ago.

Download all attachments as: .zip

Change History (7)

Changed 10 months ago by Lukáš Zaoral

Changed 10 months ago by Lukáš Zaoral

Attachment: manjaro-no-ninja-4.3.4.txt added

comment:1 Changed 9 months ago by mornfall

What versions of build software were involved? I can't reproduce this with cmake 3.14.3 and GNU make 4.2.1, not even with highly parallel builds and when removing the files in question -- they get rebuilt automatically as they should.

comment:2 Changed 9 months ago by Lukáš Zaoral

The versions of build software are following:

Manjaro - GNU Make 4.2.1, CMake 3.15.2
Fedora 30 - GNU Make 4.2.1, CMake 3.14.5

It seems, that the issue may be related to newer CMake versions.

comment:3 Changed 4 months ago by Lukáš Zaoral

Milestone: 4.34.4
Priority: minormajor
Summary: Make failure without ninja - Divine 4.3.4cmake: Build of 4.4.2 fails due to missing target dependencies

The problems shown in enclosed reports now appear also in parallel builds (with or without ninja) starting with release 4.4.2. The following patch adds missing target dependencies so that both parallel and serial builds of Divine are successful (tested on latest releases of Fedora, Debian and Arch Linux).

Changed 4 months ago by Lukáš Zaoral

Attachment: target_deps.patch added

comment:4 Changed 4 months ago by Henrich Lauko

Resolution: fixed
Status: newclosed

Fix should appear in the next release.

Note: See TracTickets for help on using tickets.